Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6064 Reply

    leo

    I’m trying to use PDFPlug with the Unity game engine. Unity generates an Xcode project. But when I include the PDFPlug framework to “Link with Binary Libraries” (I also added the necessary stdc++ and libz libraries), I get the following linking errors.

    http://pastebin.com/yDQPkqX8

    Do you have any suggestions to fix this problem? Thanks.

    #6067 Reply

    Dr. Plug
    Moderator

    hi Leo,

    In your error log I found the line ‘export IPHONEOS_DEPLOYMENT_TARGET=4.3’. However, the PlugPDF SDK for iOS supports XCode 5.0.2 or later and iOS 5.1 or later. Would you mind to change the iOS Deployment Target as iOS 5.1? Please update the result. Could you please email me at ‘support@plugpdf.com’ to continue this discussion instead of using the forum? It would be good for a faster response.

    Thanks a lot,

    #6116 Reply

    leo

    I fixed the error by linking to libc++.dylib.

    #6119 Reply

    Dr. Plug
    Moderator

    Hi Leo,

    Thanks for your feedback. For iOS simulator build libc++.dylib is required additionally.

    Thanks a lot.

    #7120 Reply

    kollpip

    Wow! Finally I got a web site from where I be capable of truly get helpful information concerning my study and knowledge.

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Xcode linkage error "undefined symbols for architecture armv7"
Your information: