Viewing 10 posts - 1 through 10 (of 14 total)
  • Author
    Posts
  • #6906 Reply

    Thomas Hilzendegen

    Hi,

    is it possible to disable the zooming completely? In our case a PDF (paper size A4) with an image (completely filling the page) together with some free-hand annotations allocates 2GB of RAM (in the simulator) when zoomed and then moved in zoomed state.

    Cheers,
    Thomas

    #6914 Reply

    Dr. Plug
    Moderator

    Hello Thomas,

    yes it is possible and very easy just, add this line in onCreate method
    PropertyManager.setIgnoreZoomGesture(true)

    Thank you
    Dr. Plug

    • This reply was modified 1 year, 8 months ago by  Dr. Plug.
    #6926 Reply

    Shahood

    When we change the page faster then it automatically zoomed the screen, although i had put the PropertyManager.setIgnoreZoomGesture(true) code.

    #6932 Reply

    Dr. Plug
    Moderator

    Hi Shahood,

    Thanks your inquiry. But actually that property is only ignore gesture about zoom (like pinch, double tap).

    Thank you,
    Dr. Plug

    #6952 Reply

    Thomas Hilzendegen

    Hi,

    thank you for your answer, but how could this be done in iOS?

    Cheers,
    Thomas

    #6969 Reply

    Dr. Plug
    Moderator

    Hi Shahood,

    Unfortunately, in iOS there is no option for that function now.
    But if you can wait for a days, we’ll make it for you.

    Thank you,
    Dr. Plug

    #6980 Reply

    Dr. Plug
    Moderator

    Hi Shahood,

    We make a Option for preventing a zoom.
    It name is enableZoom which is in PlugPDFPageView.
    if you set this option disable like this,

    zoom doesn’t work.
    you can download new release version in this link.
    http://plugpdf.com/sdkfile/PlugPDF_iOS.zip

    Thank you,
    Dr. Plug

    • This reply was modified 1 year, 8 months ago by  Dr. Plug.
    • This reply was modified 1 year, 8 months ago by  Dr. Plug.
    • This reply was modified 1 year, 8 months ago by  Dr. Plug.
    #7138 Reply

    Thomas Hilzendegen

    Hi,

    after testing I cannot get this work. I tried the following either right after creating the PlugPDFViewController or in the viewDidLoad delegate:

    Did I miss anything? Is there a different way to get the PlugPDFPageView?

    During debugging I saw that the pageView method returned ‘nil’:

    (lldb) p [plugPDFViewController pageCount]
    (long long) $0 = 1
    (lldb) po [plugPDFViewController.documentView pageView:pageIdx]
    nil

    Tried this with pageIdx as 0 and 1 (in case you started internally with 1).

    Cheers,
    Thomas

    #7139 Reply

    Thomas Hilzendegen

    Hi,

    with my next try in viewDidAppear delegate gave me a PlugPDFPageView, but setting enableZoom to NO does nothing. So what are you currently doing in this property?

    By setting both the pinchGestureRecognizer and panGestureRecognizer to enabled = NO I can prevent those two gestures on the UIScrollView directly, but the double-tab zoom still works.

    Setting the maximumZoomScale of the UIScrollView to 1.0 breaks your navigation bar visiblity handling and moves the PDF somehow down some pixels on first touch. The navigation bar then only shows when tapping in the now bigger black area at the top.

    Cheers,
    Thomas

    #7142 Reply

    Dr. Plug
    Moderator

    Hi Shahood,

    We are so sorry about that.
    Yes you are right. There is a problem accessing to PlugPDFPageView.
    So we fixed that problem. we change the location of enableZoom from PlugPDFPageview to PlugPDFDocumentViewcontroller.
    We’ll release that version on Friday and we’ll let you know how to use them.
    Could you wait for just a one day?

    Thank you,
    Dr. Plug

    • This reply was modified 1 year, 8 months ago by  Dr. Plug.
    • This reply was modified 1 year, 8 months ago by  Dr. Plug.
Viewing 10 posts - 1 through 10 (of 14 total)
Reply To: Prevent zooming
Your information: