Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #5827 Reply

    Alex Black

    A couple of my users have recently seen this exception in the wild. I hadn’t seen it until recently. Most users don’t have this issue. Two random thoughts:
    1. Did something change in that Dec 24 release?
    2. Is PlugPDF supported on Android 2.3.6? So far I’ve only seen this on devices with that OS. I try to support 2.3.3 and newer. The only part of PlugPDF that I use is the API to open a PDF and render it as images.

    Alex

    java.lang.RuntimeException: An error occured while executing doInBackground()
    at android.os.AsyncTask$3.done(AsyncTask.java:200)
    at java.util.concurrent.FutureTask$Sync.innerSetException(FutureTask.java:274)
    at java.util.concurrent.FutureTask.setException(FutureTask.java:125)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:308)
    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1088)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:581)
    at java.lang.Thread.run(Thread.java:1019)
    Caused by: java.lang.ExceptionInInitializerError
    at com.epapyrus.plugpdf.core.PlugPDF.void init(android.content.Context,java.lang.String)(ProGuard:77)
    at com.aadhk.woinvoice.util.PDFInitTask.java.lang.Void doInBackground(java.lang.Void[])(ProGuard:39)
    at com.aadhk.woinvoice.util.PDFInitTask.java.lang.Object doInBackground(java.lang.Object[])(ProGuard:18)
    at android.os.AsyncTask$2.call(AsyncTask.java:185)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:306)
    … 4 more
    Caused by: java.lang.UnsatisfiedLinkError: Couldn’t load plugpdf: findLibrary returned null
    at java.lang.Runtime.loadLibrary(Runtime.java:429)
    at java.lang.System.loadLibrary(System.java:554)
    at com.epapyrus.plugpdf.core.PDFDocument.<clinit>(ProGuard:1309)
    … 9 more

    #5829 Reply

    Dr. Plug
    Moderator

    Hi Alex,

    I am sorry for late reply. First of all, i tried testing for the exception, but i can’t reproduce the exception about your error log. I will check out some more.
    1. Yes, i add feature about RGB565.
    2. If you use only page render feature, you can run on 2.3.3 device, But can’t use ReaderView class.

    Cheers,

    Dr. Plug

    • This reply was modified 1 year, 11 months ago by  Dr. Plug.
    #5851 Reply

    Alex Black

    I’ve got some more info: this only seems to happen on armeabi-v7a platforms. Were you able to test on that platform?

    #5859 Reply

    Dr. Plug
    Moderator

    Hi Alex,

    We tried testing on armeabi-v7a mobile, but we can’t see the same exception.  I think that there is a lost .so file while trying to draw multiple bitmaps at the same time. Please check that the .so file is used in it’s entirety and ensure that you use a multi-thread process.

    Thanks,

    Dr.Plug

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: Couldn't load plugpdf: findLibrary returned null
Your information: